KonishiLee's Blog

Rails 环境安装

系统要求

  • Mac OS X
  • 任意 Linux 发行版本(Ubuntu,CentOS, Redhat, ArchLinux …)

安装 RVM

要安装 Rails,首先还是推荐先安装 RVM,为什么要安装 RVM,在这里我觉得作为一名合格的程序开发人员来说就不用多解释了吧。

1
curl -sSL https://get.rvm.io | bash -s stable

如果上面的命令不能安装成功,试试下面的命令

1
curl -L https://raw.githubusercontent.com/wayneeseguin/rvm/master/binscripts/rvm-installer | bash -s stable

在安装的时候应该会询问你的密码

将 RVM 载入到环境

1
source ~/.rvm/scripts/rvm

检查 RVM 是否安装正确

1
2
3
rvm -v
# 输出类似就证明安装成功了
rvm 1.27.0 (latest) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com> [https://rvm.io/]

安装 Ruby

要安装 Ruby,首先用 RVM 安装 Ruby 所需要的环境

1
rvm requirements

如果上面出现一些问题,那就执行以下 sudo apt-get update,成功之后在执行

1
rvm install 2.2.1

设置 Ruby 的默认版本

1
rvm use 2.2.1 --default

检查 Ruby 是否安装正确

1
2
3
ruby -v
# 输出类似就证明安装成功了
ruby 2.2.1p85 (2015-02-26 revision 49769) [x86_64-darwin14]

修改 Gem 的源

1
gem sources --add https://gems.ruby-china.org/ --remove https://rubygems.org/

安装 Bundler

1
gem install bundler

安装 Rails

1
gem install rails

这个地方可能会报错,因为当前的 Ruby 版本为 2.2.1,可是需要在安装 Rails 的时候 Ruby 的版本必须 >= 2.2.2,要解决这个问题,我们需要执行

1
gem install rails -v 4.2.2 # 这个版本的 Rails 就不需要依赖于 Ruby 版本 >= 2.2.2

检查 Rails 是否安装正确

1
2
3
rails -v
# 输出类似就证明安装成功了
Rails 4.2.6

欢迎使用 Rails。

注意

在这里可能会出现的错误是 Rails 的版本问题

1
2
gem install thor --version="0.19.1"
gem uninstall thor --version="0.19.4"
如果喜欢这个分享,就帮忙买杯咖啡吧